I tested it on a page, but the same results so this isn’t the same issue as the navigation showing.

What I did find out however is there are two classes: intense panel and intense panel heading.

Apparantly the shortcode collapse set’s the background to black only for the “intense panel heading”, and not for the “intense panel” class. This is why the background from intense panel remains white and the border is still set to transparant 1px.

It looks like there are 2 borders overlaying each other, when I set the border of the intense panel heading to 1px white the border from intense panel thickens as well.

I hope this information helps for you to find a solution to the issue.

Perhaps it would be better to add the border attribute to the collapsibles instead of the collapse shortcode? Seeing as in most cases you’d want to use the same settings for all underlaying collapses anyway. It would make it easier to use as well.